After performing exchange partition on a partitioned table, the CDC task reports an error [CDC:ErrSnapshotTableNotFound] table 341 not found in schema snapshot

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: 分区表做了exchange partition,cdc任务报错[CDC:ErrSnapshotTableNotFound]table 341 not found in schema snapshot

| username: 我是咖啡哥

[TiDB Usage Environment] Production Environment / Testing / PoC
[TiDB Version] V7.1.0
[Reproduction Path]
After performing an exchange partition on a partitioned table, CDC reported an error.
[Encountered Problem: Phenomenon and Impact]
[Attachment: Screenshot/Log/Monitoring]

 "error": {
    "time": "2023-09-14T13:11:11.562389714+08:00",
    "addr": "1XXXX:8300",
    "code": "CDC:ErrSnapshotTableNotFound",
    "message": "[CDC:ErrSnapshotTableNotFound]table 341 not found in schema snapshot"
  }
| username: xfworld | Original post link

It seems to be a bug.

| username: 我是咖啡哥 | Original post link

It has been confirmed, it’s a bug.

| username: Billmay表妹 | Original post link

Is this correct?

| username: xfworld | Original post link

Here it is.

| username: 我是咖啡哥 | Original post link

I am not sure if the scenarios are the same. That one reported schema not found, while mine reports table not found.
Last night, I found a workaround provided by the official technical support.

  1. Find the ts of the CREATE TABLE t_xxx_p202303 DDL.
    Method: curl http://{TiDBIP}:10080/ddl/history?limit=100

  2. Modify the ticdc filter configuration to [‘dlxxx.t_txxx’, ‘dlxx.t_txxx_p*’]

  3. Use the start_ts from step 1 to load the configuration from step 2 and attempt to restore the ticdc synchronization link.

| username: system | Original post link

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.