After upgrading from 6.5.0 to 6.5.9, why can't I log in to the TiDB dashboard?

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: 6.5.0 升级到6.5.9之后, tidb dashboard 无法登录了是咋回事

| username: Jarry_zhu

【TiDB Usage Environment】Production Environment
【TiDB Version】
Upgraded from v6.5.0 to 6.5.9
【Reproduction Path】Operations performed that led to the issue
tiup upgrade
【Encountered Issue: Issue Phenomenon and Impact】
Unable to log in to the dashboard using the original password
【Resource Configuration】Enter TiDB Dashboard - Cluster Info - Hosts and take a screenshot of this page
【Attachments: Screenshot/Logs/Monitoring】

| username: changpeng75 | Original post link

Check if the cluster status is normal.

| username: Billmay表妹 | Original post link

Is it an issue with passwordless settings?

| username: madcoder | Original post link

I encountered this problem, and it was resolved by clearing the cache and refreshing the address.

| username: TiDBer_21wZg5fm | Original post link

Certificate issue, I guess.

| username: zhanggame1 | Original post link

Minor issue, just restart the database and it will be fine.

| username: 像风一样的男子 | Original post link

I guess it’s a browser cache issue.

| username: oceanzhang | Original post link

Restarting is not easy, it will kill the business.

| username: zhanggame1 | Original post link

Anyway, I encountered this issue with several library upgrades, and restarting resolved it.

| username: 随缘天空 | Original post link

You can perform a rolling restart, but it is much slower.

| username: yiduoyunQ | Original post link

  1. Try clearing the browser cache and see if it works.
  2. Use tiup cluster display to check which PD the UI is on and try restarting it. If it is the leader, transfer it first.
| username: TiDBer_RjzUpGDL | Original post link

Restart it.

| username: 有猫万事足 | Original post link

Check if this PD is the leader. If it is not the leader, you can directly restart this PD. If it is the leader, you can transfer the leadership and then restart it.

| username: 呢莫不爱吃鱼 | Original post link

First, clear the browser cache. If that doesn’t work, then restart.

| username: Soysauce520 | Original post link

I’ve encountered this before. Just refresh a few times and it will be fine.