Alert configuration for TiDB and TiKV reverts to original settings after restarting the node

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: tidb和tikv的告警配置重启节点后又恢复为原来配置

| username: 路在何chu

[TiDB Usage Environment] Production Environment / Testing / Po
4013
[Reproduction Path] What operations were performed when the problem occurred
The original configuration file set tidb_tikvclient_backoff_seconds_count to 1500, but after restarting the tikv node, it reverted to the default configuration of 10.
Is there an original configuration file that needs to be modified? I couldn’t find it after searching for a long time.

| username: 路在何chu | Original post link

The image you provided is not accessible. Please provide the text you need translated.

| username: 路在何chu | Original post link

I modified the configuration in this path, this file tikv.rules.yml.

| username: 小龙虾爱大龙虾 | Original post link

Every time the configuration is refreshed, this alert rule will be regenerated. You need to configure the monitoring rule_dir parameter, then copy all the default rules here, make changes here, and the next time the configuration is generated, it will be distributed from here. Refer to 通过 TiUP 部署 TiDB 集群的拓扑文件配置 | PingCAP 文档中心

| username: 路在何chu | Original post link

Oh, I didn’t configure this parameter rule_dir. If I don’t configure this parameter, where is the original set of configuration files? Can I modify that instead?

| username: 路在何chu | Original post link

I tested version 6.5 and did not encounter this issue, and rule_dir was not configured either.

| username: 小龙虾爱大龙虾 | Original post link

It should reset when you refresh the parameters. Try using tiup cluster reload xxx --skip-restart.

| username: 路在何chu | Original post link

It feels like the version has been optimized. I configured rule_dir in the lower version to see what happens next time I restart.

| username: Fly-bird | Original post link

Modify the configuration file, then restart.

| username: 路在何chu | Original post link

Got it, thanks.

| username: swino | Original post link

Learned.

| username: zhanggame1 | Original post link

Learned.

| username: system | Original post link

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.