BR Log Backup Failed, Prompting to Set log-backup.enable to True

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: br日志备份失败,提示log-backup.enable要设置为true

| username: TiDBer_rnBNQk1l

[TiDB Usage Environment] Production Environment / Testing / Poc
[TiDB Version]
[Reproduction Path] What operations were performed when the issue occurred
Basically default configuration
[Encountered Issue: Problem Phenomenon and Impact]
Using br for log backup, an error occurs: Unable to create task about log-backup. please set TiKV config log-backup.enable to true and restart TiKVs, but this parameter is true by default, and querying this configuration also shows true.
Are there any other parameters that need to be set?

Execution command: tiup br log start --task-name=pitr --pd ${pd_url}
–storage “s3://tidb-backup/logbackup?access-key=${access_key}&secret-access-key=${secret_access_key}&endpoint=${minio_url}”

There is no issue with performing a full backup.

[Resource Configuration]
[Attachments: Screenshots/Logs/Monitoring]
image


| username: Fly-bird | Original post link

Try setting it to true and see if the prompt is still friendly.

| username: tidb菜鸟一只 | Original post link

Are both the cluster and br versions 7.1.1?

| username: TiDBer_rnBNQk1l | Original post link

I have tried manual settings as well, and the situation is the same. The version is 7.1.1.

| username: TiDBer_rnBNQk1l | Original post link

Solved it. The issue was that the TiKV status port was not open in the Docker deployment.

| username: system | Original post link

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.