Can a lower version of TiDB cluster use a higher version of TiCDC component?

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: 低版本的tidb集群可以使用高版本的ticdc组件吗

| username: 路在何chu

[TiDB Usage Environment] Production Environment

[TiDB Version]
4013

[Reproduction Path] What operations were performed when the issue occurred
None

[Encountered Issue: Issue Phenomenon and Impact]
The database version is 4013, and the current CDC version is also 4013. Can it be upgraded to a higher version of CDC? Has anyone tried it?

| username: changpeng75 | Original post link

You can refer to the documentation

| username: dba远航 | Original post link

Higher versions generally have backward compatibility.

| username: 路在何chu | Original post link

The compatibility looks pretty good.

| username: changpeng75 | Original post link

Still need to set up a test environment to test it.

| username: YuchongXU | Original post link

Compatible

| username: Fly-bird | Original post link

It should be possible, you can test it out.

| username: TiDBer_vfJBUcxl | Original post link

Sure.

| username: 数据库真NB | Original post link

This is not a matter of should or shouldn’t, let’s just test it.

| username: system | Original post link

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.