Commit TS must be greater than or equal to min commit TS: commit ts: 445060974279131170, min commit ts: 445060974279131171

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: commit TS must be greater or equal to min commit TS: commit ts: 445060974279131170, min commit ts: 445060974279131171

| username: 等一分钟

An error occurred when executing analyze table.

| username: zhanggame1 | Original post link

How about running it once more?

| username: 等一分钟 | Original post link

It’s still reporting an error.

| username: Billmay表妹 | Original post link

[Reproduction Path] What operations were performed when the issue occurred
[Encountered Issue: Issue Phenomenon and Impact]
[Resource Configuration] Go to TiDB Dashboard - Cluster Info - Hosts and take a screenshot of this page
[Attachment: Screenshot/Log/Monitoring]
Please follow the requirements to submit the issue and provide more information!

| username: 等一分钟 | Original post link

There are still many tables that report this error when executing analyze table. Is there something wrong with the cluster?

| username: 等一分钟 | Original post link

This table only has more than 50,000 records, but the execution plan shows 4 million.

| username: 等一分钟 | Original post link

The actrows here are not scanning 4,192,128 rows of data from the p3 table, right?

Is it looping 4,192,128 times because the count result is this much?

| username: 等一分钟 | Original post link

Does this have any relation?

| username: 等一分钟 | Original post link

After setting these two parameters, it still reports an error.

| username: 等一分钟 | Original post link

The commit TS must be greater than or equal to the min commit TS: commit ts: 445060974279131170, min commit ts: 445060974279131171
This value is the same every time.

| username: Kongdom | Original post link

Try this solution:

| username: 等一分钟 | Original post link

Thank you!

| username: Kongdom | Original post link

:joy: Got caught up in the drama myself. Came back from a business trip and our company’s testing environment reported a similar error~awkward~