Deployment Issues

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: 部署问题

| username: TiDBer_yangxi

[TiDB Usage Environment] Production Environment / Testing / Poc
[TiDB Version]
[Reproduction Path] What operations were performed when the issue occurred
[Encountered Issue: Issue Phenomenon and Impact]
[Resource Configuration] Go to TiDB Dashboard - Cluster Info - Hosts and take a screenshot of this page
[Attachments: Screenshots/Logs/Monitoring]
The comments in tidb_dashboard_servers have some that say PD, but they are actually incorrect, right?
252 tidb_dashboard_servers:
253 # # The IP address of the PD Server.
254 - host: 172.31.3.137
255 # # SSH port of the server.
256 # ssh_port: 22
257 # # port of TiDB Dashboard
258 # port: 12333
259 # # TiDB Dashboard deployment file, startup script, configuration file storage directory.
260 deploy_dir: “/data/tidb-deploy/tidb-dashboard-12333”
261 # # PD Server data storage directory.
262 data_dir: “/data/tidb-data/tidb-dashboard-12333”
263 # # PD Server log file storage directory.
264 log_dir: “/data/tidb-deploy/tidb-dashboard-12333/log”
265 # # numa node bindings.
266 # numa_node: “0,1”
When I check the file, it always reports an error at line 259, but this line is a comment,
Error: Failed to parse topology file ./topology.yaml (topology.parse_failed)
caused by: yaml: line 259: did not find expected key
If I comment out this whole section, there is no problem.

| username: TiDBer_yangxi | Original post link

If this service is not enabled, can we still use the dashboard from the lower version of PD?

| username: tidb菜鸟一只 | Original post link

Is there an issue with the YAML format you configured?

| username: TiDBer_yangxi | Original post link

It seems like I didn’t align it properly, but it’s fixed now.

| username: 小于同学 | Original post link

Take a look at the configuration.

| username: linnana | Original post link

In version 6.5, I encountered an issue where a part of the configuration file was written incorrectly.

| username: Aaronz | Original post link

This is still a formatting issue. Use an editor that supports YAML to adjust it outside, then paste it in, and it should be fine.

| username: system | Original post link

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.