DM 7.6 Synchronization Task Error

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: dm 7.6同步任务报错

| username: TiDBer_OB4kHrS7

[TiDB Usage Environment] Production Environment / Testing / Poc
[TiDB Version]
[Reproduction Path] Use DM 7.6 to synchronize MySQL 8.0 to MySQL 8.0
[Encountered Issues: Issue Phenomenon and Impact]
[Resource Configuration] Go to TiDB Dashboard - Cluster Info - Hosts and take a screenshot of this page
[Attachments: Screenshots/Logs/Monitoring]

| username: onlyacat | Original post link

Please share the DM cluster topology.
dial tcp 10.8.94.143:8262: connect: connection refused

Can you ping it?

| username: 像风一样的男子 | Original post link

Judging by the error, it seems there is an internal error with the DM-master service. Is the DM cluster functioning normally?

| username: TiDBer_OB4kHrS7 | Original post link

Sure, you can telnet to all of them.

| username: TiDBer_OB4kHrS7 | Original post link

The image is not visible. Please provide the text you need translated.

| username: 像风一样的男子 | Original post link

Judging by the error code, it seems to be an internal communication issue between components. How about trying to restart the nodes one by one?

| username: TiDBer_OB4kHrS7 | Original post link

Looking at the error log of work, it says there is an issue with the SQL mode parameter on the target end 8.0. The 8.0 sql_mode no longer has this parameter.

| username: dba远航 | Original post link

There should be an issue with the configuration file syntax.

| username: TiDBer_OB4kHrS7 | Original post link

It shouldn’t be. If there was an issue with the configuration file, the task would have reported an error directly and wouldn’t proceed with the export and import. This error occurred after the import was completed, during the binlog synchronization.

| username: 像风一样的男子 | Original post link

How does this seem similar to that bug? Theoretically, DM version 7.0 and above should have fixed it.

| username: 像风一样的男子 | Original post link

You can set the sql_mode in downstream TiDB to remove NO_AUTO_CREATE_USER.

| username: tidb菜鸟一只 | Original post link

Set it in the configuration file,

| username: yulei7633 | Original post link

Check if there are any restrictions on the internal network.

| username: Billmay表妹 | Original post link

Currently, DM officially only supports TiDB as the downstream.

There are no plans to support MySQL as the downstream for now. It is recommended to use TiDB products when using TiDB components.

| username: Billmay表妹 | Original post link

His downstream is MySQL hhh

| username: 像风一样的男子 | Original post link

Alright, my eyesight isn’t good, I thought the downstream was TiDB.

| username: TiDBer_OB4kHrS7 | Original post link

The same error occurs this way. I saw your reply in another post, providing a temporary solution: set the sql_mode of the downstream to be the same as the upstream, and remember to remove NO_AUTO_CREATE_USER because this option has been removed in MySQL 8. Then use binlog skip in DM to skip this error. How do you skip this error from the binlog?

| username: system | Original post link

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.