DM synchronization uses GTID, but after master-slave switch, it prompts that the binlog file cannot be found

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: dm同步数据使用了gtid,但是主从切换后提示binlog文件找不到了

| username: TI表弟

【TiDB Usage Environment】V7.5.0
【TiDB Version】
【Reproduction Path】What operations were performed when the issue occurred
【Encountered Issue: Issue Phenomenon and Impact】
【Resource Configuration】Go to TiDB Dashboard - Cluster Info - Hosts and take a screenshot of this page
【Attachments: Screenshots/Logs/Monitoring】
Task Configuration File

Normal Running State


After Master-Slave Switch

{
    "result": true,
    "msg": "",
    "sources": [
        {
            "result": false,
            "msg": "[code=38032:class=dm-master:scope=internal:level=high], Message: some error occurs in dm-worker: ErrCode:36069 ErrClass:\"sync-unit\" ErrScope:\"upstream\" ErrLevel:\"high\" Message:\"get binlog event error: ERROR 1236 (HY000): Could not find first log file name in binary log index file\" Workaround:\"Please check if the binlog file could be parsed by `mysqlbinlog`.\" , Workaround: Please execute `query-status` to check status.",
            "source": "xxx",
            "worker": "dm-xxxxxip-8262"
        }
    ],
| username: xfworld | Original post link

GTID does not rely on binlog records and will automatically locate.
Refer to this configuration

If there are issues with binlog, it is recommended to enable this feature:

| username: TI表弟 | Original post link

Big boss, you’re the best. It’s already resolved, thank you.

| username: TiDBer_JUi6UvZm | Original post link

:+1: :+1:

| username: DBAER | Original post link

Mark it.

| username: system | Original post link

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.