During BR Backup File Restoration, It Remains in Switch to Import Mode

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: br备份文件恢复时,一直处于switch to import mode

| username: 答辩潮人

[TiDB Usage Environment] Production Environment
[TiDB Version] v4.0.15
[Reproduction Path]
[Encountered Problem: Problem Phenomenon and Impact]
When restoring files backed up by BR to another empty instance, the BR progress always stops at 52%, and the log keeps printing “switch to import mode.” Stopping once and then re-importing results in the same issue.

[Resource Configuration] Go to TiDB Dashboard - Cluster Info - Hosts and take a screenshot of this page
[Attachments: Screenshots/Logs/Monitoring]

| username: TiDBer_C33 | Original post link

I encountered this before as well. No matter how many times I retried, it would get stuck at this stage for a while. I just had to wait it out. :joy:

| username: 答辩潮人 | Original post link

I have already waited for a day, I can’t wait any longer.

| username: tidb狂热爱好者 | Original post link

Too old.

| username: DBAER | Original post link

You can use top and strace to see what it’s doing.

| username: 答辩潮人 | Original post link

Are there specific instructions?

| username: zhaokede | Original post link

Version 4.x, that’s quite an old version.

| username: 考试没答案 | Original post link

Is it possible that the large batch of data being imported triggered the balance scheduling? Check these parameters, either limit the import speed or increase the scheduling parameter values.

| username: 考试没答案 | Original post link

How large is the data exported by BR??

Or try limiting the speed when importing to see.

| username: 答辩潮人 | Original post link

Cannot modify this data in import mode.

| username: 答辩潮人 | Original post link

Reducing the value here has no effect.

| username: Jasper | Original post link

Check if there are any errors in the tikv logs of the target cluster during the import?