Error Encountered by Beginners When Installing a Cluster

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: 新手安装集群报错

| username: 爱学习的TiDBer

[TiDB Usage Environment] Test
[TiDB Version] 7.0
[Reproduction Path]
tiup cluster deploy tidb-test v7.0.0 ./topology.yaml --user root [-p] [-i /home/root/.ssh/
[Encountered Issue: Problem Phenomenon and Impact]
tiup is checking updates for component cluster …
Starting component cluster: /home/tidb/.tiup/components/cluster/v1.11.3/tiup-cluster deploy tidb-test v7.0.0 ./topology.yaml --user root [-p] [-i /home/root/.ssh/

Error: none of ssh password, identity file, SSH_AUTH_SOCK specified (tui.id_read_failed)

Currently, it’s just a single machine installation for testing.
It seems to be a configuration file issue, but I don’t know how to adjust it.

global:
user: “tidb”
ssh_port: 22
deploy_dir: “/tidb-deploy”
data_dir: “/tidb-data”

pd_servers:

  • host: 192.168.147.128

tidb_servers:

  • host: 192.168.147.128

tikv_servers:

  • host: 192.168.147.128

monitoring_servers:

  • host: 192.168.147.128

grafana_servers:

  • host: 192.168.147.128

alertmanager_servers:

  • host: 192.168.147.128
| username: tidb菜鸟一只 | Original post link

tiup cluster deploy tidb-test v7.0.0 ./topology.yaml --user root -i /home/root/.ssh/
In this way,
-i specifies the key path
-p prompts for password input

| username: xingzhenxiang | Original post link

If the root password is unified, it is recommended to use -p as it is simpler and does not require passwordless authentication.

| username: 春风十里 | Original post link

Didn’t enter the root password, right?

| username: 秋季番Oo | Original post link

According to the error message, no authentication method was provided. You can add the -i or -p parameter to the startup command as suggested in the first post.

| username: system | Original post link

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.