Error Encountered When Installing and Deploying TiDB Using TiUP

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: 使用tiup安装部署Tidb时遇到报错

| username: TiDBer_NSA5APwd

When deploying TiDB, the topology.yml file has already been written, but the error shown in the picture occurred.

| username: TiDBer_NSA5APwd | Original post link

I have already executed local_install.sh

| username: Minorli-PingCAP | Original post link

Try using the TiDB user and follow the official documentation step by step to reinstall it offline.

| username: srstack | Original post link

Try using tiup list tidb to check the version.

| username: tony5413 | Original post link

According to the screenshot, the error occurs during the download. First, check the network and domain name resolution.

| username: 我是咖啡哥 | Original post link

First, check if the current mirror location is correct.

tiup mirror show

If it is a local offline mirror, check if the server package and toolkit package have not been merged.

| username: TiDBer_NSA5APwd | Original post link

Offline installation, but tiup mirror show has no output.

| username: ffeenn | Original post link

Follow this document step by step for offline deployment, installation package issue.
Deploy a TiDB Cluster Using TiUP | PingCAP Docs

| username: TiDBer_NSA5APwd | Original post link

Thank you everyone, I have found the problem. The main issue was that the default configuration in the topology.yml file sets the architecture version to amd64, while my machine is an arm64 version. This caused the installation to look for the amd version of the image. Therefore, it is necessary to add the configuration item arch: “arm64” in the configuration file.

| username: ffeenn | Original post link

:+1:

| username: Kongdom | Original post link

It didn’t get checked out during the check.

| username: liuis | Original post link

Be smarter, it should automatically detect the system version :sweat_smile:

| username: Kongdom | Original post link

It is recommended to deploy the new LTS version, as version 4.0 is a bit outdated.

| username: Running | Original post link

I feel like the network is down.