Error: failed to backup to s3://backup-p1, because the checkpoint mode is used, but the hashs of the configs are not the same. Please check the config: [BR:Common:ErrInvalidArgument]invalid argument

hello ,plse help me to fix that error

This error may be caused by the previous failed import of tidb lighting. Please refer to the documentation (TiDB Lightning Checkpoints | PingCAP Docs) for repair

You can try resetting tables that were not imported successfully using the command first, and then re execute tidb-lighting to import them:

tidb-lightning-ctl --checkpoint-error-destroy='`schema`.`table`'

If it still cannot work, you can consider deleting the relevant files that store the checkpoint status, deleting the tables that have been successfully imported, and then re executing the tidb-lighting import task.

  • /tmp/CHECKPOINT_SCHEMA.pb
  • /tmp/tidb_lightning_checkpoint.pb

Please checkout your lightning config, did you forget to use the -config flag to specify your tidb-lightning.toml configuration file?

[Lightning:Config:ErrInvalidConfig]tikv-importer.backend must not be empty!

Reference Document: Physical Import Mode | PingCAP Docs


Please use your schema name / table name to replace:

tidb-lightning-ctl --checkpoint-error-destroy=‘your_schema_name .your_table_name

Sorry, my mistake, and I made mistakes that you were using lighting for data recovery.

Error: GC safepoint 448573330246336512 exceed TS 448490393896747009: [BR:Backup:ErrBackupGCSafepointExceeded]backup GC safepoint exceeded.

If the task is stopped for a long time and multiple versions of the data have been garbage collected, the error BR:Backup:ErrBackupGCSafepointExceeded is reported when you attempt to restart the task. In this case, you have to create a new log backup task in another --storage directory.

Reference: TiDB Log Backup and PITR Command Manual | PingCAP Docs

Error: failed to backup to s3://y-tidb-log-tables-backup-v1/, because the checkpoint mode is used, but the hashs of the configs are not the same. Please check the config:`

I think it’s because you changed the config using the command line parameter ‘–send-credentials-to-tikv=false’, as the error message suggests, in the checkpoint mode (Incremental backup), you shouldn’t modify any parameters.

Please consider specify another s3 bulket and rerun the br command, or deleting the files that were previously backed up and uploaded to the s3 bucket s3://y-tidb-log-tables-backup-v1 , and rerun the br command.