Error in BR Backup to S3

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: BR备份至S3错误

| username: TiDBer_QYr0vohO

[TiDB Usage Environment] Production Environment / Testing / Poc
Testing
[TiDB Version]
v7.1.0
[Reproduction Path] What operations were performed when the issue occurred
None
[Encountered Issue: Issue Phenomenon and Impact]
Both tiup and tikv nodes use AWS IAM to access S3, with the highest level of permissions. Currently, executing aws s3 cp can copy data to S3.

tiup br backup full --pd “10.24.5.123:2379” --backupts ‘2023-06-14 10:40:00’ --storage “s3://prod-tidb-backup/data/full-backup/snapshot-202306141040” --ratelimit 128
[Resource Configuration]
[Attachments: Screenshots/Logs/Monitoring]
AWS S3 operation:


Component Status:

BR Error:

| username: 像风一样的男子 | Original post link

Try adding a parameter --s3.region.

| username: TiDBer_QYr0vohO | Original post link

Added. Another error appeared, it seems to be a prompt about the access key.

| username: TiDBer_QYr0vohO | Original post link

The image is not visible. Please provide the text you need translated.

| username: 像风一样的男子 | Original post link

Add whatever is missing. Add the S3 address with
?access-key=${access-key}&secret-access-key=${secret-access-key}

| username: TiDBer_QYr0vohO | Original post link

I have configured IAM access to S3 for all machines, do I still need to add this? I’ll give it a try.

| username: TiDBer_QYr0vohO | Original post link

No, it directly returns a 403. I saw in the documentation that IAM should work directly like this.

| username: TiDBer_QYr0vohO | Original post link

The problem has been resolved. The official technical response stated that BR uses a US URL, and if accessing domestic S3 using IAM, there will be issues. It can only be accessed using the access key/secret method. Currently, it has been switched to access S3 using the access key.

| username: system | Original post link

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.