Error in DM during Load Phase

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: DM在Load阶段报错

| username: 孤君888

[TiDB Usage Environment] Production Environment / Testing / Poc
[TiDB Version]
v7.1.1
[Reproduction Path] What operations were performed to encounter the issue
[Encountered Issue: Issue Phenomenon and Impact]

My upstream is MYSQL5.7, and downstream is TIDB-Server. Now, I am using the DM tool to perform full + incremental synchronization of a database. When executing tiup dmctl query-status MY_TASK_NAME, I get the following error:

Task configuration is as follows:

The corresponding parameter configuration for TIDB-SERVER is as follows:
image

image

image

[Resource Configuration] Go to TiDB Dashboard - Cluster Info - Hosts and take a screenshot of this page
[Attachments: Screenshots/Logs/Monitoring]

| username: 这里介绍不了我 | Original post link

This is not suggesting you adjust the parameters.

| username: Miracle | Original post link

Do I need to adjust MySQL’s max_allow_packet?

| username: 孤君888 | Original post link

All adjustments have been made, but the error persists.

| username: 孤君888 | Original post link

I also adjusted it, but I didn’t adjust it to 1G…

Isn’t this screenshot taken during the Load phase? I was thinking that the Load phase shouldn’t have anything to do with the MySQL upstream, right?

| username: 江湖故人 | Original post link

Try adding two zeros at the end directly.
Data Migration FAQ | PingCAP Documentation Center

| username: 孤君888 | Original post link

You can’t just fill in this value randomly, the documentation says so.

| username: tidb菜鸟一只 | Original post link

Increase it. I have set it to 1G on my side. If you are migrating, you can reduce it after the migration is complete…

| username: 孤君888 | Original post link

Is the documentation incorrect?

| username: 江湖故人 | Original post link

Yes, it is recommended to be a multiple of 1024, and 6710886400 is still compliant.
Even if it doesn’t comply, it’s not a big issue as the system will automatically round down.

Try changing it temporarily and see.

| username: 孤君888 | Original post link

I’ll try setting it to 10G.

| username: 这里介绍不了我 | Original post link

Is it effective?

| username: 孤君888 | Original post link

I changed max_allowed_packet to 10G, but it didn’t take effect. When I checked, it was still 1G. I also resumed the task, but the error persisted. However, the progress bar moved forward a little bit.

| username: tidb菜鸟一只 | Original post link

Indeed, it can only be changed to 1G. Mine is also 1G. I misspoke earlier; it should be performance.txn-total-size-limit set to 10G.

| username: kkpeter | Original post link

If max_allowed_packet is already 1G, you can reduce the number of rows per batch.

| username: 孤君888 | Original post link

Okay, let me try again.

| username: seiang | Original post link

Try to set

  • The global variable max_allowed_packet of the TiDB Server
  • The configuration item target-database.max-allowed-packet in the task configuration file

For detailed content of the DM configuration file, please refer to: DM 任务完整配置文件介绍 | PingCAP 文档中心

| username: 孤君888 | Original post link

It doesn’t seem to be due to this parameter. I just modified it to 10G and resumed the task, but the error still persists.

| username: ShawnYan | Original post link

Take a look at the TiDB server logs.

| username: ShawnYan | Original post link

What does the table structure of that log table look like? How can it be so large, is it all blobs?