Error in TiDB Incremental Update

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: tidb增量更新报错

| username: TiDBer_KP4konSf

panic error: table checkpoint position: (mysql-bin.003579, 507505991), gtid-set: 0-3-3410297632 less than global checkpoint location(position: (mysql-bin.003579, 507505057), gtid-set: 0-2-3410297633) (flushed location(position: (mysql-bin.003579, 507505057), gtid-set: 0-2-3410297633)),

| username: 有猫万事足 | Original post link

Can you check the data source configuration?

Whether to enable GTID

enable-gtid: false

It seems that your upstream MySQL master-slave switch occurred. The GTID changed, and DM did not set enable-gtid=true.

| username: 大飞哥online | Original post link

The source MySQL didn’t enable GTID, right? It’s using the traditional POS, right?

| username: Fly-bird | Original post link

The experts’ replies are very professional.

| username: Jellybean | Original post link

Is your incremental update from MySQL to TiDB? What is the synchronization tool and its version?

| username: forever | Original post link

New pos number, old gtid?

| username: Kongdom | Original post link

You can refer to this

| username: TiDBer_KP4konSf | Original post link

I have set it in the configuration file.

| username: Kongdom | Original post link

Did it not take effect after setting?

| username: andone | Original post link

Is GTID enabled?