Error Running Dumpling

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: 运行dumpling报错

| username: 胡杨树旁

I want to install the dumpling tool on the server to remotely back up TiDB data. After installation, an error occurs when running it.


Operating system:


I saw that the official documentation says it supports operating systems version 7.3 and above. Is it because my operating system version is too low?

| username: tidb菜鸟一只 | Original post link

What version of dumpling are you using? However, your system version is indeed too low.

| username: 啦啦啦啦啦 | Original post link

See if you can switch to a higher version of the operating system, this one is indeed a bit outdated.

| username: 胡杨树旁 | Original post link

The version of dumpling chosen is 4.0.16, and this dumpling was copied from another production environment where it is being used normally. I’ll try using a higher version server to see if it works.

| username: 胡杨树旁 | Original post link

Hmm, let me try switching to a higher version.

| username: zhanggame1 | Original post link

Just download the latest version from the official website, it’s backward compatible anyway.

| username: redgame | Original post link

It’s hard to guess this error.

| username: ShawnYan | Original post link

You’re using RHEL 5.4, which reached end-of-life several years ago. I recommend switching to a newer system.

| username: hey-hoho | Original post link

The kernel version is too old and the netpoll package cannot be found. Upgrade the system.

| username: hey-hoho | Original post link

Refer to the minimum system requirements for running Golang:

| username: cassblanca | Original post link

I remember the first Linux system I encountered after graduating from university was Red Hat AS 5.4. At that time, 5.4 had already been out for several years. Now, it’s been 10 years since I graduated…

| username: 胡杨树旁 | Original post link

Yes, after switching to a higher version of the system, it worked.

| username: 胡杨树旁 | Original post link

Yes, the version was too low. After switching to a higher version, it works fine.

| username: ShawnYan | Original post link

If you’re interested, you can try upgrading the kernel version. Maybe it will work.

| username: system | Original post link

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.