Error Using tiup cluster: Timeout

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: 使用tiup cluster 报错,超时

| username: 气死人的萌新

[TiDB Usage Environment] Test Environment
[TiDB Version] v6.1.0
[Reproduction Path]
[Encountered Problem: Problem Phenomenon and Impact]
Yesterday, I experimented with dumpling, lightning, and sync, and modified some environment variables. After the test was completed, I didn’t perform any other operations. Today, it won’t start up, showing an unknown component. I tried updating the cluster component and similar actions, but none worked. There is a snapshot that can restore it to normal, but I want to know how to solve this issue, or if a newbie made a mistake. I hope the experts can provide some guidance.
Problem Screenshot


It also says that the cluster component was not found, possibly deleted, but the files are still in the cluster path.
Environment Variable Screenshot

Cluster Path
image

[Attachment: Screenshot/Log/Monitoring]

| username: zhanggame1 | Original post link

Did you use the same user for testing yesterday and today? Try both the root and tidb users.

| username: 气死人的萌新 | Original post link

Yes, it’s the same user who has been using TiDB all along.

| username: Kongdom | Original post link

When executing the command, you are using the root user, right? Try switching to the tidb user.

| username: 啦啦啦啦啦 | Original post link

Check if the contents inside /root/.tiup/components/cluster are still there.

| username: 气死人的萌新 | Original post link

Here.

| username: 气死人的萌新 | Original post link

I have always used the root user to execute commands.
This is my configuration file at that time.
image

| username: 气死人的萌新 | Original post link

I just found out that the monitoring is actually working, all components are online, it’s just the cluster that’s having issues.

| username: Kongdom | Original post link

For standard deployment, it should be done under the tidb user. You can try switching to the tidb user and then executing the tiup command.

| username: tidb菜鸟一只 | Original post link

Take a look at what your tiup mirror is set to with tiup mirror show. If you can access the internet, you can set it to this:

tiup mirror set https://tiup-mirrors.pingcap.com
| username: TiDBer_嘎嘣脆 | Original post link

Execute tiup mirror merge ../tidb-community-toolkit in the server directory…

| username: tidb菜鸟一只 | Original post link

Then check if your components are still in
/home/tidb/.tiup/components
If not, after setting the above mirror, you can re-download them.

| username: redgame | Original post link

Redownload, it’s safer.

| username: WinterLiu | Original post link

Learned.