Error When Disabling Placement Rules

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: 关闭placement-rules报错

| username: Kongdom

[Test Environment for TiDB]
[TiDB Version] v7.1.0
[Reproduction Path]
An error occurs when executing the shutdown statement. Is it not possible to shut down when there is a TiFlash node?

| username: dba远航 | Original post link

To use TiFlash nodes, placement rules must be enabled, which means that if there are TiFlash nodes, placement rules cannot be disabled.

| username: Kongdom | Original post link

I didn’t see any similar explanation in the official documentation. :thinking:

| username: xfworld | Original post link

Anyway, it’s a test environment, so try everything.

| username: 小龙虾爱大龙虾 | Original post link

That’s right, TiFlash relies on the placement rule feature.

| username: andone | Original post link

It should not be able to be turned off.

| username: h5n1 | Original post link

Cancel the TiFlash table and set it up after merging.

| username: dba远航 | Original post link

Take a look at the relevant content in training video 302.

| username: Kongdom | Original post link

The tiflash table has been canceled, thinking of reducing the load on the test environment by scaling down the tiflash component.

| username: Billmay表妹 | Original post link

Looking forward to some replies on this. If there are any relevant constraints, let’s write a document requirement and have the documentation team add this section to the documentation.

| username: Kongdom | Original post link

:thinking: Hmm hmm

| username: Kongdom | Original post link

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.