Excessive Memory Usage in TiCDC

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: Ticdc内存使用过多

| username: zxgaa

[TiDB Usage Environment] Production Environment
[TiDB Version] v6.1.0
[Reproduction Path] High memory usage by ticdc
[Encountered Problem: Symptoms and Impact]
ticdc and tidb are deployed together, ticdc occupies too much memory, causing tidb to frequently OOM
[Resource Configuration]

[Attachments: Screenshots/Logs/Monitoring]


| username: tidb菜鸟一只 | Original post link

When using TiCDC to synchronize a wide table with a single row larger than 1k, it is recommended to set the TiCDC parameter per-table-memory-quota so that per-table-memory-quota = ticdcTotalMemory / (tableCount * 2). ticdcTotalMemory is the memory of a TiCDC node, and tableCount is the number of target tables synchronized by a TiCDC node.

| username: redgame | Original post link

How large is the table? Over 200GB of memory didn’t work.

| username: zxgaa | Original post link

Tables with tens of millions of rows

| username: cassblanca | Original post link

Reduce single table memory quota, adjust concurrency, and upgrade TiCDC version.

| username: zxgaa | Original post link

Is it possible to upgrade the version of TiCDC separately? We don’t want to upgrade all TiDB components.

| username: cassblanca | Original post link

Of course! TiCDC Installation, Deployment, and Cluster Maintenance | PingCAP Documentation Center Tidb is such an excellent product.

| username: zxgaa | Original post link

Without upgrading, I adjusted the worker-number parameter of sink-uri and the worker-num parameter of mounter, and the memory usage decreased.

| username: system | Original post link

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.