Experts, please help me with this issue. How can this problem be resolved?

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: 各位大佬帮忙看下问题,这个问题如何解决

| username: TiDBer_STGGd1J1

[TiDB Usage Environment] Production Environment
[TiDB Version] V6.5.1
[Reproduction Path] What operations were performed when the issue occurred
[Encountered Issue: Issue Phenomenon and Impact]
[Resource Configuration] Go to TiDB Dashboard - Cluster Info - Hosts and take a screenshot of this page
[Attachments: Screenshots/Logs/Monitoring]


image
First, the data source for synchronization is the slave database. Secondly, GTID was enabled upstream before the error started occurring. Can any experts take a look and see if there’s a way to resolve this?

| username: zhaokede | Original post link

Check if there is an issue with the binlog log file.

| username: wangkk2024 | Original post link

Check the logs.

| username: TiDBer_21wZg5fm | Original post link

Check the logs first if there are any issues.

| username: DBAER | Original post link

This should be when the upstream adjusts to enable GTID, there are some anonymous transactions.

| username: QH琉璃 | Original post link

Take a look at the logs.

| username: xfworld | Original post link

After GTID is enabled, has the replica been reset for consistency and synchronized via GTID?
If not, just reset the replica and rerun DM.

| username: dba远航 | Original post link

After GTID is enabled, synchronization must be performed using GTID.

| username: okenJiang | Original post link

Does DM support configuring GTID?

| username: TiDBer_STGGd1J1 | Original post link

First, GTID was enabled upstream, and then DM was enabled.

| username: TiDBer_STGGd1J1 | Original post link

After enabling it, the same error is still reported.

| username: TiDBer_QYr0vohO | Original post link

Take a look at the logs.

| username: TiDBer_STGGd1J1 | Original post link

The image is not visible. Please provide the text you need translated.

| username: TiDBer_STGGd1J1 | Original post link

I also think so. Should we adjust the GTID_mode attribute?

| username: WalterWj | Original post link

Is the issue resolved?

| username: shigp_TIDBER | Original post link

There are several possible reasons for error 1236: 1. Issues with the original TiDB binlog logs. 2. Connection issues, including network and account problems.

| username: 舞动梦灵 | Original post link

If GTID is enabled, it should be enabled upstream first, and then configured in DM. It seems that DM also needs to be configured with GTID parameters.

| username: mono | Original post link

The upstream has been configured. DM can work without using GTID. Specify the log position and resynchronize!

| username: Jack-li | Original post link

Check the logs, then solve the problem.