Failed to Create Data Source in DM

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: dm 创建数据源失败

| username: Hacker_suny

[TiDB Usage Environment] Production Environment
[TiDB Version] v4.0
[Reproduction Path]

After setting up the minimal DM according to the documentation, log in to the command interaction interface:
tiup dmctl --master-addr 127.0.0.1:8261

[Encountered Problem: Problem Phenomenon and Impact]

operate-source create ./sharding_t.yaml
fail to run: [operate-source create ./sharding_t.yaml]
Error: rpc error: code = Unimplemented desc = unknown service pb.Master

[Resource Configuration]
8c16g

[Attachments: Screenshots/Logs/Monitoring]

| username: xfworld | Original post link

TiDB needs to be compatible with the DM version, otherwise it won’t work.

You need to confirm this.

| username: 考试没答案 | Original post link

Yes, TiDB and DM must be used together, otherwise there will be various errors. Please send me a copy of your configuration file.

| username: tidb菜鸟一只 | Original post link

This error is usually caused by an incompatibility between the TiDB cluster version and the DM version in the DM deployment configuration. Specifically, it may be due to using a combination of DM version and TiDB cluster version that are not compatible, or due to incorrect names or addresses of TiDB cluster components in the DM deployment configuration.

It is recommended to check whether the TiDB cluster version and component names or addresses used in the DM deployment configuration are correct, and ensure that the DM version and TiDB cluster version are compatible. You can try updating the DM version or TiDB cluster version, or check whether the TiDB-related configuration parameters in the DM deployment configuration are correct, such as TiDB address, port, username, password, etc.

| username: Hacker_suny | Original post link

global:
user: “tidb”
ssh_port: 22
deploy_dir: “/dm/deploy”
data_dir: “/dm/data”
server_configs:
master:
log-level: info
worker:
log-level: info

master_servers:

  • host: ip01
    name: master1
    ssh_port: 22
    port: 8284
    peer_port: 8291

worker_servers:

  • host: ip01
    ssh_port: 22
    port: 8261

monitoring_servers:

  • host: ip01

grafana_servers:

  • host: ip01

alertmanager_servers:

  • host: ip01
| username: Hacker_suny | Original post link

So that means I have to set up another TiDB when setting up DM?

| username: 考试没答案 | Original post link

Still not working? Configured like this?

| username: 考试没答案 | Original post link

Is it not possible to upgrade DM and TiDB to the same version?? Do you have multiple sets of TiDB?

| username: Hacker_suny | Original post link

I have a TiDB 4.0 with a DM, but I need to set up another DM.

| username: liuis | Original post link

Delete and redo, the versions need to be the same.

| username: Hacker_suny | Original post link

What do you mean by the version compatibility you mentioned?
I currently have a set of TiDB version 4.0 and a set of DM.

The current requirement is to set up an additional new DM.

| username: Hacker_suny | Original post link

There is no version 4.0 for DM; it jumped directly from 2.0.7 to 5.3.0.

| username: Hacker_suny | Original post link

Does DM require any additional configuration, such as the address of PD?

| username: Hacker_suny | Original post link

Deleted and created a new version 2.0, same error.

| username: Billmay表妹 | Original post link

Your DM version needs to be consistent with the TiDB version. If your DM version is 5.3.0, then you need to upgrade TiDB to 5.3.0.

| username: xfworld | Original post link

Refer to @Billmay’s cousin’s answer. Additionally, you can only set up a version of DM that is compatible with TiDB 4.0, not a higher version, as it is not compatible.

| username: Hacker_suny | Original post link

The port is incorrect; it should be 8284.

| username: system | Original post link

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.