Failed to Scale Out tidb_server

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: 扩容tidb_server失败

| username: 等一分钟

tiup cluster check ./scale-out_tidbserver.yaml --user tidb
tiup is checking updates for component cluster …
A new version of cluster is available:
The latest version: v1.11.1
Local installed version: v1.6.0
Update current component: tiup update cluster
Update all components: tiup update --all

Starting component cluster: /home/tidb/.tiup/components/cluster/v1.6.0/tiup-cluster /home/tidb/.tiup/components/cluster/v1.6.0/tiup-cluster check ./scale-out_tidbserver.yaml --user tidb

  • Detect CPU Arch
    • Detecting node 10.0.254.170 … Error
    • Detecting node 10.0.254.171 … Error

Error: failed to fetch cpu arch: executor.ssh.execute_failed: Failed to execute command over SSH for ‘tidb@10.0.254.171:10086’ {ssh_stderr: , ssh_stdout: , ssh_command: export LANG=C; PATH=$PATH:/bin:/sbin:/usr/bin:/usr/sbin /usr/bin/sudo -H bash -c “uname -m”}, cause: ssh: handshake failed: ssh: unable to authenticate, attempted methods [none publickey], no supported methods remain

Verbose debug logs have been written to /home/tidb/.tiup/logs/tiup-cluster-debug-2023-02-01-17-33-39.log.

| username: 等一分钟 | Original post link

Is my command incorrect for the first expansion after cluster installation?

tiup cluster check ./scale-out_tidbserver.yaml --user tidb

| username: 等一分钟 | Original post link

You need to add a -p parameter, but it cannot accept a password.

| username: 我是咖啡哥 | Original post link

SSH is not working, the password might be incorrect, or SSH passwordless login is not configured.

| username: xingzhenxiang | Original post link

I usually use root for scaling, which will automatically create a tidb user. Do you have a tidb user on your new machine?

| username: ealam_小羽 | Original post link

If SSH mutual trust is not an issue, try adding --ssh system.

| username: 胡杨树旁 | Original post link

The TiDB user SSH did not pass. Is it because mutual trust is not configured? You can use the root user to automatically create the TiDB user and configure mutual trust.