How to Disable TiDB from Starting

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: tidb 如何禁止开启启动

| username: 程序员小王

I set up a single-node TiDB cluster on a VMware virtual machine.
The startup command is:

tiup cluster start watchpoint

However, the TiDB cluster starts automatically every time the machine boots.

I want to start it manually, but the query command:

enable      Enable a TiDB cluster automatically at boot

doesn’t have a command to disable automatic startup.

| username: DBRE | Original post link

The components of TiDB are managed by systemd, and you can use systemctl disable xxxx.service to disable the auto-start of each component at boot.

| username: 啦啦啦啦啦 | Original post link

tiup cluster disable
Refer to this link:

| username: zhanggame1 | Original post link

systemctl disable

| username: redgame | Original post link

tiup cluster disable cluster-name

| username: tidb菜鸟一只 | Original post link

Disabling a cluster with tiup cluster disable <cluster-name> means disabling the auto-start of components on all nodes using systemctl disable <service>.

| username: liuis | Original post link

tiup cluster disable cluster-name

| username: system | Original post link

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.