How to Modify the Alert Address Redirection in the TiDB Dashboard Interface

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: tidb dashboard界面告警地址跳转如何修改

| username: xie123

[TiDB Usage Environment] Production Environment
[TiDB Version] v6.5.5
[Reproduction Path] What operations were performed when the issue occurred
[Encountered Issues: Issue Phenomenon and Impact]

  1. Grafana and Alertmanager are bound to the internal IP. When the dashboard interface jumps, it also accesses the internal address. How can I modify the jump address? Or bind a proxy for the installed Grafana.
  2. The custom monitoring method also seems unable to solve the issue: https://docs.pingcap.com/zh/tidb/v6.5/customized-monitor-in-tiup-environment
    [Resource Configuration] Go to TiDB Dashboard - Cluster Info - Hosts and take a screenshot of this page
    [Attachments: Screenshots/Logs/Monitoring]
| username: WalterWj | Original post link

Manually fill in to activate the network.

| username: xie123 | Original post link

What network should be activated, and where should the address be filled in?

| username: WalterWj | Original post link

You can also modify the /etc/hosts file of your access IP, converting all internal network addresses to the external network addresses you have enabled.

| username: dba远航 | Original post link

This is bound when the cluster starts, and it is estimated that the cluster configuration file needs to be modified.

| username: 啦啦啦啦啦 | Original post link

The internal communication of the TiDB cluster uses a separate switch similar to the 192.168 type of internal network. We have also encountered similar issues. Although the performance theoretically would be better, the cluster internally only recognizes internal network addresses. To view monitoring and alerts, you have to manually input the corresponding base network IP addresses.

| username: Fly-bird | Original post link

The link here cannot be modified; you can only navigate manually.

| username: 江湖故人 | Original post link

Set up an Nginx configuration for reverse proxy.