How to Modify the Current Configuration of TiKV Parameter storage.scheduler-worker-pool-size=16

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: TiKV 当前配置 修改参数storage.scheduler-worker-pool-size=16,如何修改

| username: TiDBer_xmQUZWpA

[TiDB Usage Environment] Production Environment / Testing / PoC
[TiDB Version]
[Reproduction Path] What operations were performed that led to the issue
[Encountered Issue: Issue Phenomenon and Impact]
tikv parameter storage.scheduler-worker-pool-size=4
Need to adjust the parameter storage.scheduler-worker-pool-size=16
How to operate???

[Resource Configuration] Go to TiDB Dashboard - Cluster Info - Hosts and take a screenshot of this page
[Attachment: Screenshot/Logs/Monitoring]
tikv parameter storage.scheduler-worker-pool-size=4
Need to adjust the parameter storage.scheduler-worker-pool-size=16
How to operate???

| username: tidb菜鸟一只 | Original post link

Can the command SET CONFIG TIKV storage.scheduler-worker-pool-size='16'; take effect?

| username: TiDBer_xmQUZWpA | Original post link

I’ll give it a try.

| username: TiDBer_xmQUZWpA | Original post link

Tried it, but it didn’t take effect.

| username: TiDBer_xmQUZWpA | Original post link

Got it, this parameter cannot be adjusted to 16, it can only be less than or equal to 8.

| username: Kongdom | Original post link

The practice here does not quite match the documentation :thinking:

| username: zhanggame1 | Original post link

How many CPUs do you have?

| username: redgame | Original post link

Write an 8 and see.

| username: tidb菜鸟一只 | Original post link

How many cores does your CPU have in total?

| username: system | Original post link

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.