How to modify the password of the upstream data source synchronization account in dmctl when using DM to synchronize data from MySQL in TiDB?

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: TiDB 使用DM从mysql进行数据同步,上游数据源同步账号的密码修改了,在dmctl如何修改?

| username: wzf0072

[Test Environment for TiDB] Testing
[TiDB Version] v6.5.0
[Reproduction Path] What operations were performed to encounter the issue
[Encountered Issue: Phenomenon and Impact] When creating a synchronization task, after creating the data source, it was found that the password did not meet security requirements. After updating the password, how to delete the data source? Or reload the data source?

[Resource Configuration]
[Attachments: Screenshots/Logs/Monitoring]

[root@DM opt]# tiup dmctl --master-addr=172.16.86.60:8261 operate-source create mysql-source-confsit8641.yaml
tiup is checking updates for component dmctl …
Starting component dmctl: /root/.tiup/components/dmctl/v6.5.0/dmctl/dmctl --master-addr=172.16.86.60:8261 operate-source create mysql-source-confsit8641.yaml
{
“result”: false,
“msg”: “[code=46007:class=scheduler:scope=internal:level=medium], Message: source config with ID mysql-replica-sit8641 already exists”,
“sources”: [
]
}

| username: 裤衩儿飞上天 | Original post link

Check the operate-source --help.

| username: songxuecheng | Original post link

The default value of tidb_dml_batch_size is 2000. You can adjust this parameter according to your needs.

| username: system | Original post link

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.