How to set the Global variable of a TiDB Cloud instance, such as tidb_skip_isolation_level_check

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: 如何 set TiDB Cloud 实例的 Global variable,比如 tidb_skip_isolation_level_check

| username: TiDBer_xue91f7A

[TiDB Usage Environment] Production Environment / Testing / PoC
[TiDB Version] 6.6.0
[Reproduction Path] What operations were performed to encounter the issue
Executed set tidb_skip_isolation_level_check=1; in the command line;
Then checked using the show global variables command, and found that tidb_skip_isolation_level_check is still OFF.
[Encountered Issue: Issue Phenomenon and Impact]
Affects upstream data writing.
[Resource Configuration] Enter TiDB Dashboard - Cluster Info - Hosts and take a screenshot of this page
[Attachment: Screenshot/Logs/Monitoring]

| username: 春风十里 | Original post link

After setting the global variable, it does not take effect in the current session but takes effect for all other sessions. You need to exit the current session and log in again for it to take effect.

| username: ShawnYan | Original post link

In the command line, \r will reconnect.

| username: dba远航 | Original post link

The command set tidb_skip_isolation_level_check=1; is a session-level setting. The show global variables command is for viewing global-level settings. Session-level settings cannot change global-level settings. If you want it to take effect at the global level, you need to use set global tidb_skip_isolation_level_check=1; and then use show global variables to see the changes take effect.

| username: andone | Original post link

Global is set globally, but does not take effect for the current session.
Session only takes effect for the current session.

| username: oceanzhang | Original post link

By default, without “global,” it is session.

| username: system | Original post link

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.