I don't know what I did, but now the cluster can't be deleted

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: 不知道自己咋搞的,现在集群都无法删除了

| username: yulei7633

The image you provided is not visible. Please provide the text you need translated.

| username: yulei7633 | Original post link

At that time, it seemed that the disk space of the monitoring node was full, so I deleted some data from the monitoring node:
rm -rf 000001*
rm -rf 000002*
rm -rf 000003*

| username: db_user | Original post link

Specify the user and it should work.

| username: yulei7633 | Original post link

How to specify?

| username: yulei7633 | Original post link

Now, whether it’s reload or stop, it always prompts: Error: Operation aborted by user (with incorrect answer ‘’) (tui.operation_aborted)

| username: yulei7633 | Original post link

The display is normal. Creating databases and tables is also normal.

| username: zhanggame1 | Original post link

Was that line copied and pasted? The prompt is incorrect.

| username: db_user | Original post link

It is estimated that it might be a user-related issue.

| username: yulei7633 | Original post link

There is no problem with this replication.

| username: yulei7633 | Original post link

The user should not have any issues.

| username: WalterWj | Original post link

Is there a space at the very beginning?

| username: yulei7633 | Original post link

I tested it, and it has nothing to do with spaces. After further testing, it indeed has to do with spaces. It’s because my CRT mode was set to newline mode, which caused spaces at the beginning. Before setting the CRT mode, there were no spaces.

| username: yulei7633 | Original post link

Sorry, it was indeed a problem caused by the space. Thank you very much.

| username: srstack | Original post link

:smiley: Actually, you can also use --yes to ignore the prompt.

| username: 爱学习的TiDBer | Original post link

It was caused by multiple spaces in front :grin:

| username: yulei7633 | Original post link

Is that so? I’ll try it next time.

| username: yulei7633 | Original post link

Yes. The issue with the crt settings caused a space at the beginning. This did not exist before.

| username: yulei7633 | Original post link

It is not a user issue; it is an input error caused by spaces.

| username: system | Original post link

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.