Ignored invalid TiDB topology information entry

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: Ignored invalid TiDB topology info entry

| username: Hacker_3qLOPggZ

[TiDB Usage Environment] Production Environment
[TiDB Version] 4.0.11
[Reproduction Path] Operations performed that led to the issue
[Encountered Issue: Problem Phenomenon and Impact]

[WARN] [tidb.go:64] [“Ignored invalid TiDB topology info entry”] [key=/topology/tidb/172.16.1.100:10080:4000/info] [value=“{"version":"v4.0.1","git_hash":"689a6b6439ae7835947fcaccf329a3fc303986cb","status_port":10080,"deploy_path":"/","start_timestamp":1594192061}”] [error=“error.topology.invalid_topology_data: TiDB info address parse failed, cause: invalid address: 172.16.1.100:10080:4000: too many colons in address”]

tidb server --advertise-address=172.16.1.100 did not add a port.

| username: Kongdom | Original post link

It feels like the address configured in the TiDB node’s configuration file is incorrect.

| username: hey-hoho | Original post link

Why are there two ports written? Please share the deployment configuration file.

| username: xfworld | Original post link

You definitely filled in the wrong configuration :yum:

Two port numbers

| username: 大飞哥online | Original post link

Check the configuration file.

| username: Hacker_3qLOPggZ | Original post link

Started directly through the command line, definitely did not specify the port.

| username: xfworld | Original post link

[key=/topology/tidb/172.16.1.100:10080:4000/info]

10080
4000
What kind of configuration is this… :rofl:

| username: Fly-bird | Original post link

key=/topology/tidb/172.16.1.100:10080:4000/info

| username: hey-hoho | Original post link

Please describe the operation process.

| username: Kongdom | Original post link

Please share the startup command.

| username: Hacker_3qLOPggZ | Original post link

tidb-server
–cors=*
–store=tikv
–metrics-interval=30
–path=172.16.1.1,172.16.1.2,172.16.1.3
–proxy-protocol-networks=172.16.1.17,172.16.1.246
–metrics-interval=30
–advertise-address=172.16.1.100

| username: 像风一样的男子 | Original post link

172.16.1.100:10080:4000 This was written incorrectly in the configuration search.

| username: Kongdom | Original post link

Try adding the port in the startup command.
It is recommended to use tiup for deployment.

| username: 像风一样的男子 | Original post link

Replied to the wrong person.

| username: Kongdom | Original post link

Try adding the -P port in the startup command. Additionally, the path should also include the port.
It is recommended to use tiup for deployment.

| username: Hacker_3qLOPggZ | Original post link

Reply to the previously mentioned PD port.
Found this issue on GitHub: error.topology.invalid_topology_data can't recover · Issue #19801 · pingcap/tidb · GitHub
Same situation.

| username: Kongdom | Original post link

Understood. Please provide the Chinese text you would like translated into English.

| username: Hacker_3qLOPggZ | Original post link

Mainly, I haven’t found a solution yet. :joy:

| username: Kongdom | Original post link

:thinking: Isn’t it because the PD port wasn’t specified?

| username: Hacker_3qLOPggZ | Original post link

No, it’s resolved.
Using the HTTP API of PD to view etcd data doesn’t work.

Deleting this key with etcdctl solves the problem.

The reason is that when starting tidb-server for the first time, the advertise-address parameter included 10080. After correction, PD does not replace this data, causing this alert.