Is there a corresponding TiSpark driver for TiDB 7.1.3?

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: tidb7.1.3有对应的tispark驱动吗

| username: TiDBer_tR0NzRuF

I would like to inquire which version of the TiSpark driver corresponds to TiDB 7.1.3. I checked the official website at TiSpark 用户指南 | PingCAP 文档中心, but there doesn’t seem to be a corresponding version.

| username: Billmay表妹 | Original post link

Try using the latest 3.2.x version.

| username: juecong | Original post link

Using Spark 3.3.x normally in version 7.1.1

| username: TiDBer_tR0NzRuF | Original post link

Got it. Thank you very much.

| username: TiDBer_tR0NzRuF | Original post link

Okay, I’ll test it.

| username: TiDBer_QYr0vohO | Original post link

Take a look at this, see which versions of Spark your TiSpark version is compatible with.

| username: yytest | Original post link

You can try Spark version 3.3.

| username: ShawnYan | Original post link

Choosing the latest is never wrong.

| username: zhaokede | Original post link

For testing, choose the latest version; for production, choose the stable version.