Issue of Balance Speed Control When Node Goes Online

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: 节点上线-balance速度控制问题

| username: magongyong

[TiDB Usage Environment] poc
[TiDB Version]
v6.5.2
[Reproduction Path] Operations performed that led to the issue
Scaling out tikv
tiup cluster scale-out t2 ./scale-out-tikv.yaml

[Encountered Issue: Phenomenon and Impact]
I want to control the online speed to prevent impacting the production business. I checked the documentation and modified the parameters as shown in the screenshot, but the changes did not take effect.
Modifications are as follows:
region-schedule-limit changed from 2048 to 20480
max-pending-peer-count changed from 64 to 512
max-snapshot-count changed from 64 to 512

The speed has always been 15-20MB, as shown below

Which parameters can control the node online speed?

[Resource Configuration] Go to TiDB Dashboard - Cluster Info - Hosts and take a screenshot of this page
[Attachments: Screenshots/Logs/Monitoring]

| username: Kongdom | Original post link

:astonished: You have set it the wrong way. The documentation says increasing the value is to speed up, not to avoid affecting the business. If you don’t want to affect the business, you should appropriately decrease the parameter.

| username: dba-kit | Original post link

These metrics are actually all about adjusting the speed of generating scheduling plans. If you want to adjust the online speed, you also need to adjust the consumption speed of TiKV, which means adjusting the store limit. You can refer to the official documentation: Store Limit | PingCAP 文档中心

| username: dba-kit | Original post link

PS: By default, the store limit is only 50, which is already very low and has minimal impact on cluster performance.

| username: zhanggame1 | Original post link

Generally, it’s best not to adjust the default parameters. Only make changes if you encounter issues.

| username: magongyong | Original post link

Currently in the testing phase, let’s see which parameters need to be set.

| username: magongyong | Original post link

Okay, thank you.

| username: magongyong | Original post link

Okay, got it. I’ll look into it.

| username: magongyong | Original post link

Okay, thank you.

| username: system | Original post link

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.