Issue with Configuration Not Taking Effect

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: 加了配置不生效问题

| username: TiDBer_TVKpabeM

[TiDB Usage Environment] Production Environment / Testing / Poc
[TiDB Version]
[Reproduction Path] What operations were performed when the issue occurred
Modified configuration in tiup cluster edit-config tidb-test
a6ed0b6175d85aed55b2f9fd8babbc3
[Encountered Issue: Issue Phenomenon and Impact]
0111aa1e9027f36f4a1de13df845640
Still not effective in MySQL
[Resource Configuration] Go to TiDB Dashboard - Cluster Info - Hosts and take a screenshot of this page
[Attachments: Screenshots/Logs/Monitoring]

| username: 啦啦啦啦啦 | Original post link

This is a system variable, directly set it globally in TiDB using set global.

| username: zhanggame1 | Original post link

The method of adding is incorrect. It should be added at the session level or globally with global.

Set the memory usage threshold for the entire SQL to 8GB:

SET tidb_mem_quota_query = 8 << 30;

Set the memory usage threshold for the entire SQL to 8MB:

SET tidb_mem_quota_query = 8 << 20;

Set the memory usage threshold for the entire SQL to 8KB:

SET tidb_mem_quota_query = 8 << 10;
| username: Kongdom | Original post link

Did you upgrade from a version below 6.1? You should pay attention to the release notes, as adjustments were made in version 6.1. :grinning:

| username: system | Original post link

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.