Issues Encountered While Setting Up Archery

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: 搭建Archery所遇到的问题

| username: sxli

The issues encountered while setting up and deploying Archery are as follows:
Background: The environment required for Archery has been set up, but I encountered a port occupation problem. I subjectively believe that this has nothing to do with Redis, MySQL, or MongoDB, so I pinpointed the error to Nginx’s proxy. Here, I use Nginx to start Archery, and I followed the configuration on the official website as a reference. Below is my Nginx configuration. After successfully starting Nginx, the current port occupation situation is shown below. Then, when I tried to start Archery, I encountered the port occupation issue shown in the image below. I also tried changing the port number in Nginx, but the problem still persists. Seeking help from experts.

| username: sxli | Original post link

Here I tried to shut down nginx, but even after shutting down nginx, the issue of the port being occupied still occurs.

| username: Billmay表妹 | Original post link

Is this deploying TiDB? Why not use tiup for deployment?

| username: xfworld | Original post link

Looking for a server, just deploy the services separately… :stuck_out_tongue_closed_eyes:

| username: 啦啦啦啦啦 | Original post link

Deploying with Docker is very convenient. How about considering deploying directly with Docker?

| username: dba远航 | Original post link

The port should be configurable.

| username: andone | Original post link

Recommend using tiup for deployment.

| username: ShawnYan | Original post link

Was the issue resolved in the end? Which port was being occupied?

| username: oceanzhang | Original post link

Which process to check with netstat for the port?

| username: 双开门变频冰箱 | Original post link

Use tiup

| username: lemonade010 | Original post link

We all deploy separately without using Docker, one reason is configuration issues, and the other is performance issues.

| username: 啦啦啦啦啦 | Original post link

This issue is unrelated to TiDB, so TiUP cannot be used. You either deploy each component individually or use Docker.

| username: kkpeter | Original post link

You should probably Google this; it might be faster.

| username: 小于同学 | Original post link

TiUP deployment is simpler.

| username: TiDBer_21wZg5fm | Original post link

This doesn’t seem to have much to do with TiDB.

| username: 路在何chu | Original post link

Can Archery be deployed with TiDB?

| username: oceanzhang | Original post link

Find the process for the port.

| username: 洪七表哥 | Original post link

Use netstat -tuln to see which process is occupying the port.

| username: Jack-li | Original post link

Deploying with Docker will be simpler and more convenient.