Issues with Installing and Deploying TiDB 6.5.0 on ARM+Kylin SP3 Environment

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: TIDB 6.5.0版本 在ARM+麒麟SP3环境安装部署问题

| username: TiDBer_A3Z0iZAh

[Test Environment] TiDB
[TiDB Version] 6.5.0
[Reproduction Path] Execute tiup cluster check /home/tidb/topology.yaml --user tidb -p and manually enter the correct password during installation check.
[Encountered Issue: Phenomenon and Impact] The check did not pass, error reported.
[Resource Configuration] Navigate to TiDB Dashboard - Cluster Info - Hosts and take a screenshot of this page
[Attachments: Screenshots/Logs/Monitoring]

| username: TiDBer_A3Z0iZAh | Original post link

After configuring the cluster host for passwordless access, the check passes when the -p parameter is removed. I would like to understand the specific reason why the check fails when the -p parameter is added.

| username: 小龙虾爱大龙虾 | Original post link

Adding -p prompts you to enter a password, and it requires the same password for all nodes in the cluster.

| username: TiDBer_JUi6UvZm | Original post link

The error reported is related to SSH, you need to check the password.

| username: TiDBer_JUi6UvZm | Original post link

It is recommended to set up passwordless login for each machine.

| username: zhanggame1 | Original post link

Can I use root to install? Each machine doesn’t need to have a tidb user, and it will automatically have one after installation.

| username: xiaoqiao | Original post link

SSH didn’t go through, try manual SSH.

| username: hacker_77powerful | Original post link

It has nothing to do with the ARM architecture or the Kirin processor, right?

| username: tidb菜鸟一只 | Original post link

Are you sure you didn’t enter the wrong password…?

| username: 不想干活 | Original post link

It should be an SSH password issue.

| username: Jack-li | Original post link

It doesn’t have much to do with the architecture.

| username: TIDB-Learner | Original post link

On the control machine with different IPs, use the command: ssh user@ip and try entering the password.

| username: WinterLiu | Original post link

Everyone has analyzed it thoroughly, the SSH issue.