Issues with Special Characters in Downstream Databases When Creating Changefeed in TiCDC

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: ticdc创建changefeed里下游数据库包含特殊特号的问题

| username: 扬仔_tidb

【TiDB Usage Environment】Production Environment
【TiDB Version】v5.2.2.
【Reproduction Path】Special characters in the downstream database of ticdc
【Encountered Problem: Phenomenon and Impact】
【Resource Configuration】
【Attachments: Screenshots/Logs/Monitoring】

ticdc

–sink-uri="mysql://backup:1234@123!@x.x.x.x
My password contains @! and URL encoding doesn’t work

Error as follows:

–sink-uri="mysql://backup:1234%40123!@x.x.x.x
Error -bash: !@x.x.x.x: event not found

Solution

Change double quotes to single quotes --sink-uri=‘mysql://backup:1234%40123!@x.x.x.x
Perfectly solved

| username: hey-hoho | Original post link

I have tried using URL encode for special characters before, and it works.

| username: 像风一样的男子 | Original post link

The official documentation clearly states that special characters need to be escaped.

| username: Billmay表妹 | Original post link

Solution

Change the double quotes to single quotes --sink-uri=‘mysql://backup:1234%40123!@x.x.x.x
Perfectly solved

Should I mark this as resolved?

| username: system | Original post link

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.