Kill the Running Statistics Issue

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: 杀掉正在运行的统计信息问题

| username: yulei7633

Looking at the image above, I have already killed the statistics ID, but when I query again, I can still see the statistics running. Is it impossible to kill it?

| username: yulei7633 | Original post link

Looking at the time above, it was indeed killed. Upon checking again, it automatically started again.

| username: xfworld | Original post link

Is it set to start automatically? Check the configuration to see.

| username: yulei7633 | Original post link

In the test environment, after I turned off the automatic statistics configuration, it worked fine. However, in the production environment, even after turning off the automatic statistics configuration, it still doesn’t work.

Production environment configuration:


| username: 路在何chu | Original post link

Did you log in to the corresponding TiDB node to kill it?

| username: andone | Original post link

Could this be a bug?

| username: yulei7633 | Original post link

You need to log in to the tidb-server node, which means accessing the 4000 port of tidb, and then terminate it.

| username: yulei7633 | Original post link

It feels like you need to restart the cluster to stop it, but I wouldn’t call it a bug.

| username: chenhanneu | Original post link

Manually collect the automatically collected tables and then kill them.

| username: yulei7633 | Original post link

Thank you, I understand. Since this table has 1024 partitions, even though the automatic analyze is turned off, it is necessary to collect statistics for each partition before proceeding.

| username: system | Original post link

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.