Memory Overflow

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: 内存溢出

| username: 等一分钟

Version: TiDB-v5.2.3

Default total memory control

Default single SQL memory control

A 32G memory server frequently encounters OOM

Is it not being controlled properly?

| username: 等一分钟 | Original post link

mem_max: 2905983851 Bytes (2.71 GB)
The OOM logs often report exceeding the controlled memory size.

| username: buddyyuan | Original post link

It is somewhat related to this parameter.

| username: 等一分钟 | Original post link

Okay, I’ll give it a try.

| username: 等一分钟 | Original post link

Do I need to directly set global or modify the configuration file of tiup?

| username: buddyyuan | Original post link

This is a variable, set globally.

| username: 等一分钟 | Original post link

If the TiDB cluster restarts, do the variables need to be set again?

| username: buddyyuan | Original post link

| username: 等一分钟 | Original post link

:slightly_smiling_face: Thank you

| username: 等一分钟 | Original post link

Adding TiFlash nodes, can it save the memory usage of tidb_server?

| username: system | Original post link

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.