No Data Error in Top SQL on Dashboard

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: Dashboard里Top SQL无数据报错

| username: TiDBer_mra9oJ0k

[TiDB Usage Environment] Production Environment
[TiDB Version] v8.1.0
[Reproduction Path] Operations that led to the issue:
Created a cluster in v7.5, destroyed the cluster, then created a new cluster. Encountered an error in the Dashboard with no data in Top SQL.
API: /topsql/instances
Request failed with status code 502

Attempted to scale down and scale up PD, but it was ineffective.

The issue persisted after upgrading from v7.5 to v8.1.

[Encountered Issue: Symptoms and Impact]
[Resource Configuration] Navigate to TiDB Dashboard - Cluster Info - Hosts and take a screenshot of this page
[Attachments: Screenshots/Logs/Monitoring]

| username: 这里介绍不了我 | Original post link

Is the parameter tidb_enable_top_sql enabled?

| username: TiDBer_mra9oJ0k | Original post link

This parameter is already enabled.

| username: TiDBer_mra9oJ0k | Original post link

There was an article before that described the same issue I am experiencing, but I tried the methods mentioned and they didn’t work.

| username: onlyacat | Original post link

After the error occurs, check the log on the machine where PD is deployed.

| username: TiDBer_mra9oJ0k | Original post link

Problem solved. Due to resource issues, the monitoring_servers were deployed on other machines, and the ng_port port was not open in the firewall. Thank you all!!!

| username: ziptoam | Original post link

It seems that the most basic network issues are still very likely to occur.