No slow SQL alerts in the monitoring URL of the newly deployed cluster

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: 新部署的集群监控网址里面慢sql提示没有

| username: 舞动梦灵

The newly deployed cluster shows this error message when opening the monitoring.

| username: Fly-bird | Original post link

Do you actually have slow SQL queries in your database?

| username: 舞动梦灵 | Original post link

Just deployed. Definitely not. I’m also wondering if it’s because it’s just been deployed and there’s nothing inside, so there’s no slow SQL.

| username: dba远航 | Original post link

Take a look later.

| username: 哈喽沃德 | Original post link

It’s probably due to low configuration. I’ve encountered this before. Try refreshing a few more times and see.

| username: TiDBer_vfJBUcxl | Original post link

When executing a slow SQL in the database, check if it appears in the interface.

| username: 像风一样的男子 | Original post link

The slow query log hasn’t been generated yet, right?

| username: 舞动梦灵 | Original post link

I also suspect the same. The key issue is that there are no slow SQL queries to operate on. Let’s restore the old data first. After the restoration is complete, check if querying a large table takes more than 3 seconds.

| username: zhanggame1 | Original post link

It is estimated that there needs to be a slow query log.

| username: WalterWj | Original post link

Go to the deployment directory and check if the log directory is empty.

| username: 连连看db | Original post link

Try constructing a slow query using the metadata table to see if it creates a log file for the first time.

| username: TiDBer_5Vo9nD1u | Original post link

Refresh a few more times.

| username: 舞动梦灵 | Original post link

It’s empty.

| username: WalterWj | Original post link

If it’s empty, it doesn’t make much sense :thinking:

| username: TiDBer_08RNElU3 | Original post link

The slow log file has not been generated yet.

| username: 舞动梦灵 | Original post link

Thanks, everyone. It might be that there were no slow SQL queries right after deployment. I am currently restoring data, and there are some slow SQL queries. They have been flagged.

| username: 小龙虾爱大龙虾 | Original post link

If the file is not generated, the error reported by the front-end query can be considered a minor bug and does not have a significant impact. :slightly_smiling_face:

| username: lemonade010 | Original post link

Run it a few more times.

| username: system | Original post link

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.