Online DDL Causes TiKV CPU Spike

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: 在线DDL导致tikvcpu飙升

| username: hyman

Performing an online DDL on a table with 1 billion rows, renaming the index column, then adding a new column with the same name and creating an index, has been running for 1.5 hours, and the TiKV CPU has spiked to 90%.

| username: hyman | Original post link

The current situation is that after creating the index column, it shows that it was created successfully instantly, but the TiKV CPU spiked, and the database crashed.

| username: tidb狂热爱好者 | Original post link

I don’t understand. Performing an online DDL on a table with 1 billion rows, renaming an index column, then adding a new column with the same name and creating an index, has already been running for an hour and a half, and the TiKV CPU has spiked to 90%.

| username: tidb狂热爱好者 | Original post link

I feel that your business is accessing and you changed the table structure, causing the business CPU to reach 100%.

| username: xfworld | Original post link

What’s the current situation?

| username: 特雷西-迈克-格雷迪 | Original post link

Creating large table indexes can cause TiKV CPU alarms.

| username: tidb狂热爱好者 | Original post link

I feel that your business was accessing the table structure you modified, causing the CPU to reach 100%. In reality, it was the new SQL deployed by the business that caused the CPU to reach 100%.

| username: 大鱼海棠 | Original post link

Under the default parameter behavior, adding an index does not have such a big impact on the cluster. Check the tikv-details monitoring threads-cpu and compare it with the dashboard. It seems that there are slow queries dragging down the database.

| username: xingzhenxiang | Original post link

In my 3.1.0 cluster with a total size of over 37TB, adding fields is done in seconds. Check the slow SQL queries.

| username: system | Original post link

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.