Region Issues

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: region问题

| username: yulei7633

In the production environment, the program reports the following error, please help analyze the reason.
My understanding is that the parameter value is a bit large, should this value be appropriately reduced?

| username: 芮芮是产品 | Original post link

The SQL is too large, there is a parameter setting.

| username: 芮芮是产品 | Original post link

txn-entry-size-limit Introduced from Version v5.0

  • Size limit for a single row of data in TiDB
  • Default value: 6291456
  • Unit: Byte
  • Size limit for a single key-value record in a transaction. If this limit is exceeded, TiDB will return an entry too large error. The maximum value for this configuration item does not exceed 125829120 (which means 120MB).
  • Note that TiKV has a similar limit. If the size of the data in a single write request exceeds raft-entry-max-size, which defaults to 8MB, TiKV will refuse to process the request. When a row record in a table is large, both configurations need to be modified simultaneously.
| username: 芮芮是产品 | Original post link

You are inserting too much data. Either insert less data or change from 8m to 80m.

| username: Fly-bird | Original post link

Modify the TiDB parameters or the SQL statement, the memory has exceeded.

| username: yulei7633 | Original post link

Thank you.

| username: yulei7633 | Original post link

Got it, let me make some changes and see.

| username: Kongdom | Original post link

:astonished: A single row of data exceeds 8M, how wide and large must this table be?

| username: zhanggame1 | Original post link

You can use the INSERT statement with VALUES to write multiple rows of data.

| username: zhanggame1 | Original post link

Just change the parameters and it will be fine.

| username: Kongdom | Original post link

:+1: :+1: :+1: Oh, I see, I thought it was a single record.

| username: andone | Original post link

Modify the parameter configuration.

| username: yulei7633 | Original post link

I will ask the developer to modify the size of the single-line statement and configure the parameters. Thank you all very much.

| username: system | Original post link

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.