Scaling Down Tidb-flash Using Tiup Did Not Take Effect

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: 使用tiup进行Tidb-flash缩容没有生效

| username: 哈喽沃德

[Test Environment for TiDB] Testing
[TiDB Version] 7.4.0
[Encountered Issue: Phenomenon and Impact]



tidb-flash did not initialize successfully after installation because the host CPU is not supported.

| username: xfworld | Original post link

Reinstalling should solve the issue…

TiUP will perform an environment check before installation, so it’s recommended not to skip it.

| username: ShawnYan | Original post link

What CPU are you using? Can you post the log of the unsupported part?

| username: Kongdom | Original post link

:thinking: I don’t understand what you’re trying to express. Isn’t it already known from the question that it’s caused by the CPU? Is it an issue with the instruction set?

| username: Fly-bird | Original post link

CPU not supported

| username: tidb菜鸟一只 | Original post link

Add --offline to take it offline.

| username: 哈喽沃德 | Original post link

Okay, I’ll give it a try.

| username: 哈喽沃德 | Original post link

No, it doesn’t work. It shows this.

| username: 哈喽沃德 | Original post link

Not supported, I need to delete tidb-flash and replace it with another machine.

| username: 哈喽沃德 | Original post link

How to delete those two tidb-flash instances and reassign them to other specified nodes on different machines.

| username: 哈喽沃德 | Original post link

When checked, everything passed. Now, how do I delete the tidb-flash node?

| username: 哈喽沃德 | Original post link

[root@localhost ~]# cat /proc/cpuinfo | grep avx2

| username: 哈喽沃德 | Original post link

[root@localhost ~]# cat /proc/cpuinfo | grep avx2
No output.

| username: TiDBer_小阿飞 | Original post link

Is the CPU AMD64?

| username: zxgaa | Original post link

  1. You can use tiup’s scale-in.
  2. If scale-in doesn’t work, you can use the store command in pd-ctl (the corresponding binary file is included in the resources/bin directory under tidb-ansible).
| username: Kongdom | Original post link

Add the --force parameter to force deletion

| username: 哈喽沃德 | Original post link

For amd64, but it’s a CPU from around 10 years ago.

| username: Jolyne | Original post link

tiup cluster scale-in xxx --force

| username: 哈喽沃德 | Original post link

There is a warning, reporting this error.

| username: Kongdom | Original post link

Yes, just type it out once, or you can copy and paste it. After all, this is a major issue of deleting the database and running away, so it’s understandable to confirm it multiple times.
Note, it’s not replying with yes or no, but typing out “Yes, I know my data might be lost.” which means 是的,我知道我的数据可能丢失。