SQL_MODE Configuration: Removing ONLY_FULL_GROUP_BY Ineffective After Restart

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: SQL_MODE配置,去除ONLY_FULL_GROUP_BY重启失效

| username: TiDBer_4bUGKwNP

[Test Environment for TiDB] Testing
[TiDB Version] 7.1.1
[Reproduction Path]
SET GLOBAL sql_mode= ‘STRICT_TRANS_TABLES,NO_ZERO_IN_DATE,NO_ZERO_DATE,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION’;
SET SESSION sql_mode= ‘STRICT_TRANS_TABLES,NO_ZERO_IN_DATE,NO_ZERO_DATE,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION’;
[Encountered Problem: Phenomenon and Impact] Need to reset after restart. Is there a way to set it by default at startup, similar to the my.cnf configuration file in MySQL?
[Resource Configuration]
[Attachment: Screenshot/Log/Monitoring]

| username: tidb菜鸟一只 | Original post link

After setting sql_mode to global, will it be persisted to the cluster?

| username: Jellybean | Original post link

“Users need SUPER privileges to set the GLOBAL level SQL mode,” this permission needs to be checked.

According to the official documentation, it is possible to set global system variables, and once set, global system variables will be persisted to the cluster. Ideally, the situation you mentioned should not occur.

| username: Kongdom | Original post link

Is it executing set session? Global should be persistent.

| username: zhanggame1 | Original post link

Global is persistent. If the setting is lost after restarting the server, you can report a bug.

| username: Fly-bird | Original post link

Is it at the global level?

| username: system | Original post link

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.