SSH Error When Verifying TiDB 6.5.0 Cluster Deployment on openEuler 22.03

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: openEuler 22.03部署安装tidb6.5.0验证群集时ssh报错

| username: GG_gg

[TiDB Usage Environment]
Test Environment
Operating System: openEuler release 22.03 (LTS-SP3)
SSH Version:
libssh-0.9.6-7.oe2203sp3.x86_64
libssh2-1.10.0-5.oe2203sp3.x86_64
openssh-8.8p1-23.oe2203sp3.x86_64
openssh-server-8.8p1-23.oe2203sp3.x86_64
openssh-clients-8.8p1-23.oe2203sp3.x86_64

[TiDB Version]
v6.5.0

[Reproduction Path]
Manually configure mutual trust, create a tidb user, and set up passwordless SSH from the control machine to other machines (passwordless login is possible from the control machine to other machines’ tidb users).

[Encountered Issue: Problem Phenomenon and Impact]
During cluster detection, only one machine has an SSH issue. According to the error, it might be unable to execute the command sudo -H bash -c “/tmp/tiup/bin/insight” on 172.17.10.219. I have manually executed this command on each machine, and all other machines return information except for 172.17.10.219, which returns “2024/02/05 23:32:58 exit status 127”.
I have also checked that the environment variables for both root and tidb users are consistent across all machines.

[Attachments: Screenshots/Logs/Monitoring]
Error during deployment verification

Passwordless login from control machine 172.17.10.18 to 172.17.10.19:

Execution of sudo -H bash -c “/tmp/tiup/bin/insight” on 172.17.10.219 returns:
image

Execution of sudo -H bash -c “/tmp/tiup/bin/insight” on 172.17.10.220 returns:

| username: 春风十里 | Original post link

In version V6.5, there is no support for openEuler 22.03 LTS SP1.


In version V7.5, it is clearly stated that openEuler 22.03 LTS SP1 is supported.
TiDB Software and Hardware Environment Recommendations | PingCAP Documentation Center

It is recommended to download TiDB 7.5 and try again

| username: YuchongXU | Original post link

Not supported, possibly an SSH version issue.

| username: dba远航 | Original post link

Use echo $SHELL to check if the current shell is bash.

| username: GG_gg | Original post link

I also tried 7.5 and it’s the same. All four of my machines are running openEuler 2203, but only one of them has this issue, which is very strange.

| username: GG_gg | Original post link

All four of my machines are running openEuler 2203, but only one of them is like this. It’s very strange.

| username: GG_gg | Original post link

Okay, let me take a look.

| username: GG_gg | Original post link

172.17.10.219 (SSH issue displayed when verifying the cluster):
image

172.17.10.220 (No SSH issue displayed when verifying the cluster):
image

| username: tidb菜鸟一只 | Original post link

Can you paste the contents inside /tmp/tiup/bin/insight? You can try executing it separately to see why this machine is reporting an error.

| username: 哈喽沃德 | Original post link

Could it be an issue with the SSH version?

| username: GG_gg | Original post link

I used ‘cat’ to check, but it’s garbled. I’m not sure what language it’s written in. It seems like files can’t be uploaded here.

| username: GG_gg | Original post link

The SSH versions on my four machines are all the same.

| username: 哈喽沃德 | Original post link

The operating system version is the same, right? I still feel it’s an environment variable issue because the other machines don’t have this problem.

| username: 哈喽沃德 | Original post link

If it doesn’t work, try setting the same password on several machines first.

| username: 哈喽沃德 | Original post link

Is SELinux disabled?

| username: Soysauce520 | Original post link

Did you grant sudo permissions?

| username: 哈喽沃德 | Original post link

Why don’t you use root?

| username: WinterLiu | Original post link

It seems to be an issue with the environment variables.

| username: zhanggame1 | Original post link

If you install directly as the root user, using -u root -p, the tidb user will be automatically created and set to password-free.

| username: GG_gg | Original post link

SELinux is disabled, and the environment variables for the root and tidb users are set the same as on other machines.