The default value of ticdc enable-old-value is true and cannot be changed to false, what should I do?

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: ticdc enable-old-value 默认值是true,不能改成false,咋办?

| username: LKLK

[TiDB Usage Environment] Production Environment / Testing / PoC
[TiDB Version]
[Reproduction Path] What operations were performed when the issue occurred
[Encountered Issue: Issue Phenomenon and Impact]
[Resource Configuration] Go to TiDB Dashboard - Cluster Info - Hosts and take a screenshot of this page
[Attachments: Screenshots/Logs/Monitoring]

The online V5.4 TiDB cluster uses TiCDC to synchronize data to Kafka, but because there are too many data columns, the default value of TiCDC’s enable-old-value is true, resulting in too much data volume. Therefore, I want to change it to false, but starting the task reports an error [CDC:ErrOldValueNotEnabled] old value is not enabled. How can I modify it or is there another way to handle it?

| username: Rilakkuma | Original post link

How did you change it to false? Did you restart the changefeed?

| username: redgame | Original post link

Is this the one that was changed? replication-task.yaml
enable-old-value: false

| username: LKLK | Original post link

Changing it to false will result in an error, indicating [CDC:ErrOldValueNotEnabled] old value is not enabled. I just want to know if there is any other way to set enable-old-value to false.

| username: Rilakkuma | Original post link

What version of CDC?

| username: LKLK | Original post link

5.4.0

| username: Anna | Original post link

You need to refer to the synchronization limitations: TiCDC 简介 | PingCAP 文档中心

| username: system | Original post link

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.