The monitoring shows TiKV as 20, but normal stores are 19

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: 监控上显示tikv为20 ,normal stores 却是19

| username: xingzhenxiang

【TiDB Usage Environment】Production Environment / Testing / PoC
【TiDB Version】
【Reproduction Path】What operations were performed when the issue occurred
【Encountered Issue: Monitoring shows 20 TiKV, but normal stores are 19】
【Resource Configuration】
【Attachments: Screenshots / Logs / Monitoring】

| username: db_user | Original post link

Run pd ctl and check the result of store, and also use TiUP cluster display to see the actual result.

| username: xingzhenxiang | Original post link

The result of the display

| username: db_user | Original post link

tiup ctl:v6.5.1 pd -u http://pd_ip:2379 store, what does the result look like? Are there also 20 of them, and are they in a normal state?

| username: xingzhenxiang | Original post link

This is the information of the store, and it is also 20. I don’t know which value the normal state is taken from?

stores.txt (22.6 KB)

| username: 考试没答案 | Original post link

Check if the Prometheus configuration file is set to 20. If not, try restarting Prometheus and see if that helps.

| username: 考试没答案 | Original post link

Last time I encountered an issue with the number of TiKV instances being incorrect. I restarted Prometheus and it was resolved.

| username: xingzhenxiang | Original post link

The configuration file is 20, mainly obtaining information from PD, normally it is not 20.

| username: 考试没答案 | Original post link

How many does the dashboard show???

| username: db_user | Original post link

The normal query statement is this: sum(pd_cluster_status{tidb_cluster=“$tidb_cluster”, instance=“$instance”, type=“store_up_count”})
You can check it on Prometheus at http://prometheus_ip:9090
Run pd_cluster_status, click execute to see the result, and send the result to take a look.

| username: xingzhenxiang | Original post link

The image you uploaded is not visible. Please provide the text you need translated.

| username: db_user | Original post link

Got it, there’s an abnormal status, which is the status of slow_count.

You can troubleshoot according to the official documentation. You should receive an alert, check the corresponding TiKV status, load, network, and other conditions.

| username: xingzhenxiang | Original post link

Got it, I’ll take a look.

| username: system | Original post link

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.