TICDC Error ErrGCTTLExceeded, etcdserver: request is too large

This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: TICDC报错ErrGCTTLExceeded,etcdserver: request is too large

| username: TiDBer_7E0yINhK

[TiDB Usage Environment] Production Environment
[TiDB Version] 5.1.1
[Reproduction Path]
Expand and install two CDCs
Start CDC to synchronize all data (do not specify database tables, use the default current time)
[Encountered Problem: Phenomenon and Impact]
After running for 24 hours, it reports an error ErrGCTTLExceeded (stable reproduction)
[Resource Configuration]
[Attachment: Screenshot/Log/Monitoring]
There is an error related to etcd in cdc.log

What could be the reason?

| username: Jiawei | Original post link

It looks like the request is too large. Check if the max_allowed_packet on the source and target ends are consistent. You might consider adjusting this parameter to see if it helps.

| username: TiDBer_7E0yINhK | Original post link

Where can this parameter be modified? I couldn’t find this parameter in INFORMATION_SCHEMA.CLUSTER_CONFIG.

| username: Jiawei | Original post link

I was mistaken. This parameter was only introduced in version 6.0. I remember it used to be 64M by default.

| username: neilshen | Original post link

Known issues in the old version: changefeed stuck, log has "etcdserver: request is too large...owner exited with error" · Issue #2083 · pingcap/tiflow · GitHub

It might be due to too many tables being captured within a single changefeed. It is recommended to:

  1. Capture only the necessary tables for business purposes to reduce the number of tables being captured.
  2. Upgrade TiCDC to the latest version.