TiCDC synchronization often exceeds GC TTL

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: ticdc同步经常超过gc ttl

| username: TiDBer_hwEZA4rV

[TiDB Usage Environment] Production Environment / Testing / Poc
[TiDB Version] 6.5.2
[Reproduction Path] What operations were performed when the issue occurred
[Encountered Issue: Issue Phenomenon and Impact]
[Resource Configuration]
[Attachment: Screenshot/Log/Monitoring]
{
“id”: “skuld2bigdata”,
“namespace”: “default”,
“summary”: {
“state”: “failed”,
“tso”: 445559156491157658,
“checkpoint”: “2023-11-11 11:28:15.941”,
“error”: {
“addr”: “192.168.86.77:8300”,
“code”: “CDC:ErrGCTTLExceeded”,
“message”: “[CDC:ErrGCTTLExceeded]the checkpoint-ts(445559156491157658) lag of the changefeed({default skuld2bigdata}) has exceeded the GC TTL”
}
}
},

The error of exceeding the GC time often occurs. How can it be resolved?

| username: Daniel-W | Original post link

What is the current setting for GC TTL?
First, analyze the reason for the task being stuck. Is there any large transaction or other operations?

| username: andone | Original post link

There are large transactions or long transactions.

| username: Fly-bird | Original post link

Reset the GC TTL.

| username: 小龙虾爱大龙虾 | Original post link

Let’s first analyze the reasons for the slow synchronization.

| username: Soysauce520 | Original post link

Limit large transactions and check if it’s an oversized delete.

| username: 路在何chu | Original post link

Set it larger, isn’t the default not enough for a day?