TiDB Deployment Issues

Note:
This topic has been translated from a Chinese forum by GPT and might contain errors.

Original topic: tidb部署问题

| username: 烂番薯0

At the end of the deployment, this sentence appears, and the log shows the following. What is the reason for this?

| username: dba远航 | Original post link

Confirm that SSH authentication between machines has been completed.

| username: tidb菜鸟一只 | Original post link

Are you using the root user or the tidb user?

| username: 像风一样的男子 | Original post link

Manually execute scp to see what error it reports, and confirm whether it is a permission issue or a password-free issue.

| username: 烂番薯0 | Original post link

Passed

| username: 烂番薯0 | Original post link

I am using a TiDB user, and I have set up passwordless authentication.

| username: zhanggame1 | Original post link

Deploying with --user root is more convenient, as it eliminates the need to add the tidb user and set up passwordless access on each machine; it does it automatically for you.

| username: 烂番薯0 | Original post link

I also tried using root, but it still couldn’t be sent from the local machine.

| username: zhanggame1 | Original post link

Root requires the root password to be the same for all machines. Please send your deployment command. Using root for deployment does not require configuring mutual trust.

| username: 烂番薯0 | Original post link

My root user password is the same, and the tidb user is also password-free, and the root user is also password-free, but I just can’t use scp on the local machine. I don’t know why.

| username: zhanggame1 | Original post link

Is manual SCP not working either? Also, have you set up passwordless authentication on your local machine? Do you need a password when using manual SSH?

| username: 烂番薯0 | Original post link

Manual method doesn’t work either. Passwordless SSH is set up on the local machine, and manual SSH doesn’t require a password. The error occurs when transferring storage/cluster/packages/tikv-v6.5.0-linux-amd64.tar.gz to tidb@10.237.103.68:/opt/tidb/tidb-deploy/tikv-20160/bin/tikv-v6.5.0-linux-amd64.tar.gz: Process exited with status 1.

| username: 烂番薯0 | Original post link

The image is not visible. Please provide the text you need translated.

| username: zhanggame1 | Original post link

No password means you don’t need the -p parameter.

| username: 烂番薯0 | Original post link

Yes, I tried it without adding the parameter p, but it still reported this error. My machine doesn’t have scp, so I manually scp the tar package over. The other nodes have the binary executable program.

| username: xingzhenxiang | Original post link

What is the deployment command like? I usually deploy and manage through root, and tidb is just the user for installing and running the program.

| username: zhanggame1 | Original post link

There might be an issue with the downloaded package. How about cleaning the environment and starting over?

| username: Trouble | Original post link

It should be caused by incorrect installation user or password-free settings.

| username: 连连看db | Original post link

Reconfigure passwordless access.

| username: 烂番薯0 | Original post link

I switched to a new control machine for deployment, but the 68 node still doesn’t work.